FrameworkDemoiselle.gov.brCommunity Documentation

Capítulo 4. Configuração do Demoiselle Signer

4.1. Instalação do componente

Para utilizar o componente policy-impl-cades num projeto Java, basta adicionar a sua dependência no arquivo pom.xml , conforme o seu gerenciador de projetos:

  • Apache-Maven

            		<dependency>
    				<groupId>org.demoiselle.signer</groupId>
    				<artifactId>policy-impl-cades</artifactId>
    				<version>3.2.6</version>
    			</dependency>
    			

  • Apache Buildr

    'org.demoiselle.signer:policy-impl-cades:jar:3.2.6'
    			

  • Apache Ivy

    <dependency org="org.demoiselle.signer" name="policy-impl-cades" rev="3.2.6" />
    			

  • Groovy Grape

    @Grapes(@Grab(group='org.demoiselle.signer', module='policy-impl-cades', version='3.2.6'))
    			

  • Gradle/Grails

    <dependency org="org.demoiselle.signer" name="policy-impl-cades" rev="3.2.6" />
    			

  • Scala SBT

    libraryDependencies += "org.demoiselle.signer" % "policy-impl-cades" % "3.2.6"
    			

  • Leiningen

    <[org.demoiselle.signer/policy-impl-cades "3.2.6"]
    			

Caso não esteja utilizando nenhum outro tipo de gerenciador (estava morando numa caverna nos últimos dez anos), pode baixar o .jar do repositório:

http://repo1.maven.org/maven2/org/demoiselle/signer/policy-impl-cades/